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D e s i g n i n g  Y o u r  F i r s t  M o d e l

It’s finally time to get modeling! Over the 
next few chapters, you’ll gradually learn 

increasingly complex sketching tools, fea-
tures, and techniques. By the end of the book, 

you’ll be a master of 3D modeling and have the skills 
to design whatever you can think of. First, let’s start 
with the basics.

Getting to Know Your Tools
In this chapter, you’ll learn to use fundamental sketch tools and features 
in Fusion 360, which you’ll use more than any of the complex tools in the 
chapters to come. Just like how a skilled carpenter can do amazing things 
with a handful of basic tools, you’ll learn how to construct models using use 
simple tools like Extrude and Revolve. These foundational tools may not be 
glamorous or designed for specialized work, but they’re powerful and use-
ful for a wide variety of tasks.



18   Chapter 3

Using Basic Sketch Tools
You can find the basic tools under the Sketch drop-down menu, as shown in 
Figure 3-1. If you don’t see the Sketch drop-down menu, make sure you’re 
in the Model workspace.

Figure 3-1: The Sketch tools menu

You should see quite a few options here, and many of them have addi-
tional submenus. In this chapter, you’ll use the following tools:

Create Sketch  Creates a new sketch. When using this tool, you must 
select on which plane the sketch will be drawn. When you haven’t yet 
started a model, you will usually select one of the x-y, y-z, or z-x planes, 
and if you’ve already started building a model, you’ll usually select a flat 
face as a sketch plane. You can also start a sketch by selecting one of the 
sketch tools, like the Line tool, and then choosing a plane.

Line  Draws straight line segments. You can connect multiple segments 
together to form shapes. This tool is so frequently used it gets a default 
keyboard shortcut key: L.

Rectangle  Creates four line segments automatically joined with 
constraints, or rules that specify how sketch entities are linked. For 
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example, a constraint might lock the endpoints of two line segments 
together, make an arc tangent to a straight line, or make two lines par-
allel. In this case, the Rectangle tool automatically constrains the end-
points of the four lines and makes them perpendicular to each other. 
The submenu contains options for defining the rectangle, and the 
keyboard shortcut R draws two-point rectangles that are defined by  
any two corners.

Circle  Draws circles. Multiple options are available under the sub-
menu for defining and positioning the circle. Sketch circles are true 
mathematical circles—they’re not divided into arcs or a series of line 
segments. The C shortcut creates a circle defined by its centerpoint and 
diameter.

Arc  Draws arcs. The submenu provides a few options here for how you 
want to define the constraints of the arc. Since arcs aren’t as common 
as the other shapes, the Arc tool doesn’t have a keyboard shortcut.

Fillet  A fillet (pronounced “fill-it”) is a frequently-used tool for round-
ing a sketch’s corner. You define it by the radius of the arc that joins the 
two lines. When you use it in a sketch, this tool automatically cuts two 
line segments short, places an arc connecting them, and constrains that 
arc to be tangent to both line segments.

Trim  When two lines intersect, this tool trims one of the lines down 
to the point where the intersection occurs. The keyboard shortcut is T.

Extend  Extends a line until the point where it intersects with another 
line. If you apply this tool and there are no other lines to intersect, then 
nothing will happen—lines can’t go on infinitely in Fusion 360.

Offset  Creates a line, or chain of lines, that is offset from the selected 
line by a defined distance. The keyboard shortcut is O.

Sketch Dimension  Defines the dimensions of your sketches, like the 
length of a line or the angle between two lines. The keyboard short-
cut is D.

The sketch entities you create with these tools will likely form the bulk 
of your toolset—you can sketch almost anything with just these tools. But 
you’re not reading this book just to make sketches—you want to create 
3D models! That’s where features come in.

Using Initial Features
You can use the tools in the Create menu (shown in Figure 3-2) to make ini-
tial features, which you’ll combine to create 3D shapes. You must always use 
one of these initial features to create your first 3D entity because they don’t 
require any existing model geometry to work off of (though a sketch may be 
required). This contrasts with the tools from the Modify menu, which only 
work with existing geometry. Keep in mind that you can use these tools to 
create features throughout the modeling process, and not just to create ini-
tial features.
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Figure 3-2: Initial features are located under the Create drop-down menu.

Some of these initial features are more frequently used than others. 
The following list briefly describes the most common features:

Extrude  Adds thickness to a sketch to form a 3D solid. Conversely, an 
extrude feature is also used to cut into an existing solid in the shape 
of a selected sketch. This is the most common feature in 3D modeling, 
and the keyboard shortcut is E.

Revolve  Similar to Extrude, this feature creates a new solid or cuts an 
existing solid from a sketch. The Revolve feature makes a solid body by 
revolving the sketch around a selected center axis by a specified number 
of degrees. For example, a square that touches the axis of revolution 
would form a cylinder if it were revolved a full 360 degrees.

Hole  Streamlines the process of cutting a hole in a solid. With Extrude 
and Revolve, you can create a hole of any shape you can sketch, but using 
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the Hole feature can sometimes be faster for creating simple holes. But 
since cutting holes with Extrude or Revolve is more common and versa-
tile, I typically avoid using Hole.

Box, Cylinder, Sphere, Torus, Coil, and Pipe  These features create 
primitive solids. Like the Hole feature, these features can all save time in 
some situations—mostly as basic starting points—but for learning pur-
poses, you won’t be using them in this book. You can create each of these 
(with the possible exception of the Coil feature) with Extrude or Revolve.

You might be surprised that you’ll only use two of these initial features 
for now (Extrude and Revolve), but they’re powerful and useful. In fact, 
Extrude and Revolve alone will probably make up more than 90 percent of 
the initial features you use in your 3D modeling endeavors.

Modifying Features
While you can create initial features without any existing solids, you’ll need 
to have a 3D object to modify features. Modifying tools are often used toward 
the end of the modeling process to put the finishing touches on a part you’ve 
designed, but you can certainly use them earlier. You can access these tools 
from the Modify drop-down menu (see Figure 3-3).

Figure 3-3: You can find modifying features under the Modify drop-down menu.
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Like the initial features, you’ll use some of these tools more than 
others, so the following list covers just a few of the available modifying tools 
in Autodesk Fusion 360:

Fillet  Like the Fillet sketch tool, you can use the Fillet modifying tool 
to create rounded edges and corners three-dimensionally. You can select 
inside or outside edges and define a radius. The keyboard shortcut is F.

Chamfer  The Chamfer tool works much in the same way as Fillet, 
except that it gives the edge a bevel instead of rounding it. You can 
define a chamfer by the angle of the cut and one distance from an 
edge, or with the distances from two edges.

Shell  A surprisingly useful feature, the Shell tool hollows out a solid 
and removes the selected face for an opening. You also need to specify 
the thickness of the walls, so the model remains a solid. Shell could, for 
instance, turn a cylinder into a cup or a cube into a box.

Now that you know what’s in your tool belt, let’s jump into the modeling!

Modeling a Cube
Creating a cube is like the “Hello, World!” of 3D modeling. Although you can 
quickly and easily create a cube with the Box initial feature, you’ll create a 
cube the hard way from sketches so you can learn about the modeling process.

Creating the Sketch
To model the cube using an Extrude feature, you first need to start with 
a sketch. Go to the Sketch drop-down menu and select the Create Sketch 
option. You should be asked to choose a plane on which to draw the sketch. 
Figure 3-4 shows the sketch on the xy-plane. The plane you choose is com-
pletely up to you—you can always rotate models at a later point, so it’s really 
about how you want to picture the part in your mind.

Once you choose your sketch plane, the viewport should rotate to face 
that plane. You can rotate the view if you like, but most of the time you’ll 
want to sketch while facing the sketch plane.

Because you’re modeling a cube, start by sketching a rectangle. In this 
case, you want a center rectangle. This means the rectangle will be constrained 
to stay centered on the origin point, or (0, 0, 0). Constraints are geometric 
rules that apply to sketch entities. For instance, a perpendicular constraint 
forces two lines to meet at a 90 degree angle. Keeping your models con-
strained to the origin is typically good practice, because it will make using 
the default reference planes and axes easier in the future.

Now navigate to SketchRectangleCenter Rectangle. A dialog offering 
various options should pop up on your screen. Clicking the plane determines 
the centerpoint, so click the origin to automatically create the rectangle’s first 
constraint. Your next click should place a corner of the rectangle, so just click 
off in space a bit away from the origin so you get something rectangular, as 
shown in Figure 3-5. The point you click should be mirrored across both the 
x- and y-axes—automatically placing all four points of the rectangle.
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Figure 3-4: Sketch on whichever plane makes the most sense to you.

Figure 3-5: When sketching, you can define dimensions during or after the operation.
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You may have noticed that, after your second click that set the corner 
of the rectangle, the dimensions popped up for the width and height of 
the rectangle. You could have specified one of them, pressed tab, entered 
dimensions for the other, and then pressed enter. This would have defined 
the dimensions of the rectangle and constrained it to them. 

But because you didn’t do that and just clicked a point in space, Fusion 
drew the rectangle without any associated dimensions. This means that the 
rectangle is constrained to be centered on the origin, the endpoints of the 
four lines are automatically locked together with coincident constraints, 
and the four lines are constrained to be perpendicular to each other. But,  
it doesn’t have any dimensions to constrain its actual size.

Completely Constraining the Sketch
At this point, the four lines of your rectangle should be blue, which by default 
signifies that a sketch isn’t completely constrained. You should never finish a 
sketch without it being completely constrained with geometrical constraints 
or dimensions. Until the sketch is completely constrained, points and lines 
could unintentionally shift, which leads to ambiguity about the accuracy of 
the part; and when it comes to CAD, ambiguity is always bad.

To completely constrain the rectangle, you need to define the dimen-
sions of the part. Use the D shortcut to create a sketch dimension—or choose 
it from the Sketch menu—and select a vertical line. Move your cursor off to 
the side of the line and click to place the dimension. Then enter 50 and press 
enter. Do the same for one of the horizontal lines. The dimensions should 
display as shown in Figure 3-6.

Figure 3-6: Sketch lines are black once they’re fully constrained.
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Now that you’ve defined the dimensions, all the lines should turn black 
in the default Photobooth visual environment (colors may look different if 
you change the environment). That means you’ve completely constrained 
the rectangle, and nothing unexpected should happen later on that might 
affect the precision of the sketch. Ensuring sketches are always fully con-
strained should keep you from having to chase down problems when you’re 
working with more complex models. Leaving a sketch partially uncon-
strained won’t break anything, but it can cause unpredictable results if the 
sketch or features shift.

Extruding the Sketch
To extrude your completely constrained sketch to form a 3D solid, press E 
or choose CreateExtrude. The view should shift to make it easier to tell 
what your extrusion is doing, and you’ll be asked to choose a profile, which 
is any closed loop in a sketch. In this case, your profile is your rectangle, so 
click somewhere inside it. Like in Figure 3-7, the selected profile should be 
highlighted. Although it doesn’t apply here, you can select multiple profiles 
if they’re on the same plane by clicking inside them when the “profile” field 
in the dialog is active. 

Like all features, Extrude provides you with some options to work with. 
The Start option is where you want the zero point, or the start of the extru-
sion, to be. In this case, you should stick with the default, which is to start it 
at the sketch plane.

Figure 3-7: The Extrude dialog
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The Direction option determines whether the extrusion should extend 
to one side of the sketch plane, both sides with different distances, or both 
sides with symmetrical distances. You want your cube to stay centered on 
the origin point, so choose Symmetric. When you select Symmetric, you’ll 
be asked if the dimension refers to total extrusion length or per side. You 
want total so that all dimensions match. Set the Distance option to 50 mm 
with a 0 degree taper angle.

The last option, Operation, determines what the feature does. Because 
you don’t have any other solid bodies in your model, New Body is the only 
option that makes sense, but if you wanted to cut a hole in an existing body, 
you could use Cut. Other options are Intersect, which keeps just the section 
where two solids overlap, and Join, which merges two solids together.

Finally, click OK to create your very first 3D model! The finished model 
should look like the cube in Figure 3-8.

Figure 3-8: A cube, your first 3D model!

Now that you’ve completed the cube, let’s give it some more character 
with some modifying tools.

Modifying the Cube
In this section, you’ll fillet all of the cubes’ edges and cut a circular hole 
into one of its sides. Filleting the edges gives your cube a nice rounded look. 

Because Fillet is a modifying feature, you don’t have to sketch anything; 
you only need to select the edges you want to fillet. Be sure to rotate the model 
to get the back edges and choose a radius of 5 mm, as shown in Figure 3-9.
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Figure 3-9: Select edges to fillet.

To better understand how the Fillet tool works, try tinkering with the 
radius measurement and note its behavior.

To cut a hole through one side of the cube, create a new sketch. For the 
sketch plane, choose either the front or back flat face of the cube (you’ll see 
why soon). Next, sketch a Center Diameter Circle, with the center on the 
origin point and a diameter of 25 mm, as shown in Figure 3-10.

Figure 3-10: Circle drawn with centerpoint on the origin on one side of your cube
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This is why you took the time to center your rectangle around the origin 
and use a symmetric extrusion. When you select a sketch plane, the origin 
point is automatically centered on your part, because the previous features 
were modeled symmetrically around the origin. Now when you center your 
circle on the origin, you know that it’s also centered on the face of the cube. 
If your cube wasn’t centered on the origin, you’d have to use additional con-
straints, construction geometry, or dimensions to center the circle on the face.

With the circle drawn and fully constrained, you can extrude it to cut 
the hole. To execute a one-sided Extrude, set the Extent option to All so that 
it cuts through all existing solids. You may need to select the Flip toggle to 
change the direction, and then set the operation to Cut (see Figure 3-11).

Figure 3-11: Using Extrude to cut a hole

Your cube now has a hole in it—nifty! To save your model, click the 
Save icon.

Using the Design History Timeline
You may have noticed that icons have started appearing at the bottom left 
of the window in the Design History Timeline. These icons represent each 
step you’ve taken to create this particular model (see Figure 3-12). 

You can also use the Back and Forward buttons to skip back and forth 
through all of the features to see each step. You can even use the Play button 
to see a sort of time lapse of your modeling process.
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Being able to skip through the features is cool, but the true power of 
the Design History Timeline lies in its ability to modify those old features 
and sketches. When you use the timeline to make changes to an earlier 
step, all subsequent items in the Timeline should update to reflect your 
changes. Let’s give it a try!

Figure 3-12: The Design History Timeline

Right-click the second item in the Timeline—the first should be a sketch, 
and the second should be the initial extrusion. Next, click Edit Feature, and 
the original Extrude feature dialog should pop back up. Now change the 
distance from 50 mm to 100 mm and then click OK. The result should look 
like the model shown in Figure 3-13.

Figure 3-13: All of the features after the change update to reflect the change.

Notice how the edge fillets were lengthened, but the hole still goes all 
the way through the part. Thanks to the power of parametric modeling, 
Fusion 360 groups geometry into variable-driven features that adapt to 
changes. The edge itself had the fillet, so when the edge got longer, the 
fillet did too. Recall that when you extruded the hole cut, you chose the 
All option, so when the extrusion was lengthened, so was the cut.
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The reason you chose the front or back face for this feature was to  
avoid an unexpected result, like the one shown in Figure 3-14. 

Figure 3-14: The hole is on the wrong face!

In this case, the hole was extruded through one of the side faces.  
When the model was just a cube, it looked the same no matter which face 
you sketched the hole on. But when the model was extended, the hole could 
end up in the wrong place if you chose the left, right, top, or bottom faces. 
How you choose to orient models is completely up to you, as long as you keep 
in mind how the features are positioned relative to each other. 

Exercises
Practice the techniques you learned in this chapter by completing the 
following exercises on your own.

Add a Slot
Remove the hole in the block by right-clicking the corresponding feature in 
the Design History Timeline and selecting Delete. In this case, the hole fea-
ture is the last one in the Timeline. But, if you ever lose track of the features, 
you can hover your cursor over the Design History Timeline entry icons to 
highlight the corresponding feature in the model, or drag the marker back 
through the Timeline to see each modeling step.
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Now you’ll add a slot to the top face. To sketch a slot, you can use the 
Slot tool in the Sketch menu. There are different options for how to define 
it, and you’ll want to use overall length. Give it a length of 50 mm and a 
width of 20 mm. When you’re done, it should look like the model shown  
in Figure 3-15.

Figure 3-15: Add a slot to the top face of the block.

Make the Slot Responsive
As you’ve already seen, it’s important to consider how models will change 
in the future. In the first exercise, you made the slot 50 mm long—half the 
length of the block itself. Suppose you always want the slot to be half the 
block’s length, no matter what that length is.

To do that, edit the slot sketch. Under the Modify drop-down, click 
Change Parameters, and a dialog will pop up that lists all of dimensions 
used in the model (you may have to expand the submenus). Parameters 
are divided into User Parameters, which you explicitly create, and Model 
Parameters, which Fusion 360 generates automatically when you model 
new features. One of the dimensions will be the Extrude Distance of 
100 mm. Take note of its name, which was “d3” in my case. 

Next, you can modify the slot length dimension with that name so it 
says something like “d3 / 2”. Now, the slot length will always be calculated 
as being half of the extrude distance.

If you elongate the block, your model should look something like the 
model shown in Figure 3-16.
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Figure 3-16: Use parameters to make the slot length always half the block length.

Summary
Using a simple example of CAD modeling, you learned how to use 
Fusion 360’s most versatile tool: Extrude. In the following chapters,  
you’ll dive into increasingly complex features, but you’ll continue to  
use Extrude throughout this book and in all of your 3D modeling 
projects.




